Skip to main content
← All vulnerabilities
CVE-2018-1999043GHSA-2632-H32J-6RG9

A denial of service vulnerability exists in Jenkins 2.137 and earlier, 2.121.2 and earlier in BasicAuthenticationFilter.java, BasicHeaderApi

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.121.3, 2.138
None on Exploit-DB, Metasploit or GitHub

Summary

A denial of service vulnerability exists in Jenkins 2.137 and earlier, 2.121.2 and earlier in BasicAuthenticationFilter.java, BasicHeaderApiTokenAuthenticator.java that allows attackers to create ephemeral in-memory user records by attempting to log in using invalid credentials.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.121.3

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.122 · fixed in 2.138

References 1

jenkins.io