Skip to main content
← All vulnerabilities
CVE-2018-1999005GHSA-PGXV-H967-FW2Q

A cross-site scripting vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in BuildTimelineWidget.java, BuildTimelineWidg

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.121.2, 2.132
None on Exploit-DB, Metasploit or GitHub

Summary

A cross-site scripting vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in BuildTimelineWidget.java, BuildTimelineWidget/control.jelly that allows attackers with Job/Configure permission to define JavaScript that would be executed in another user's browser when that other user performs some UI actions.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.121.2

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.122 · fixed in 2.132

References 2

oracle.com

jenkins.io