Skip to main content
← All vulnerabilities
CVE-2018-1999004GHSA-WMR8-25FF-GGPJ

A Improper authorization vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in SlaveComputer.java that allows attackers

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.121.2, 2.132
None on Exploit-DB, Metasploit or GitHub

Summary

A Improper authorization vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in SlaveComputer.java that allows attackers with Overall/Read permission to initiate agent launches, and abort in-progress agent launches.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.121.2

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.122 · fixed in 2.132

References 2

oracle.com

jenkins.io