CVE-2018-18853GHSA-F94M-MQHR-MC29
Lightbend Spray spray-json through 1.3.4 allows remote attackers to cause a denial of service (resource consumption) because of Algorithmic
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.3.5
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Lightbend Spray spray-json through 1.3.4 allows remote attackers to cause a denial of service (resource consumption) because of Algorithmic Complexity during the parsing of a field composed of many decimal digits.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- io.spray:spray-json_2.12Maven
fixed in 1.3.5
- io.spray:spray-json_2.11Maven
fixed in 1.3.5
- io.spray:spray-json_2.10Maven
fixed in 1.3.5