CVE-2018-17567GHSA-4XJH-M3QX-49WC
Jekyll through 3.6.2, 3.7.x through 3.7.3, and 3.8.x through 3.8.3 allows attackers to access arbitrary files by specifying a symlink in the
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.6.3, 3.7.4, 3.8.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Jekyll through 3.6.2, 3.7.x through 3.7.3, and 3.8.x through 3.8.3 allows attackers to access arbitrary files by specifying a symlink in the "include" key in the "_config.yml" file.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- jekyllRubyGems
fixed in 3.6.3
- jekyllRubyGems
From 3.7.0 · fixed in 3.7.4
- jekyllRubyGems
From 3.8.0 · fixed in 3.8.4