CVE-2018-16886GHSA-H6XX-PMXH-3WGPGO-2021-0077
etcd versions 3.2.x before 3.2.26 and 3.3.x before 3.3.11 are vulnerable to an improper authentication issue when role-based access control
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.2.26, 3.3.11, 0.5.0-alpha.5.0.20190108173120-83c051b701d3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
etcd versions 3.2.x before 3.2.26 and 3.3.x before 3.3.11 are vulnerable to an improper authentication issue when role-based access control (RBAC) is used and client-cert-auth is enabled. If an etcd client server TLS certificate contains a Common Name (CN) which matches a valid RBAC username, a remote attacker may authenticate as that user with any valid (trusted) client certificate in a REST API request to the gRPC-gateway.
Timeline
- CVE published
- Record last updated
Affected versions
- The etcd Project etcd:
Version range not reported
- go.etcd.io/etcd/v3Go
From 3.2.0 · fixed in 3.2.26
- go.etcd.io/etcd/v3Go
From 3.3.0 · fixed in 3.3.11
- go.etcd.io/etcdGo
fixed in 0.5.0-alpha.5.0.20190108173120-83c051b701d3