CVE-2018-16854GHSA-XJ5F-QV37-R9JC
A flaw was found in moodle versions 3.5 to 3.5.2, 3.4 to 3.4.5, 3.3 to 3.3.8, 3.1 to 3.1.14 and earlier.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.1.15, 3.3.9, 3.4.6, 3.5.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
Summary
A flaw was found in moodle versions 3.5 to 3.5.2, 3.4 to 3.4.5, 3.3 to 3.3.8, 3.1 to 3.1.14 and earlier. The login form is not protected by a token to prevent login cross-site request forgery. Fixed versions include 3.6, 3.5.3, 3.4.6, 3.3.9 and 3.1.15.
Timeline
- CVE published
- Record last updated
Affected versions
- [UNKNOWN] moodle
3.6, 3.5.3, 3.4.6, 3.3.9, 3.1.15
- moodle/moodlePackagist
From 3.1 · fixed in 3.1.15
- moodle/moodlePackagist
From 3.3 · fixed in 3.3.9
- moodle/moodlePackagist
From 3.4 · fixed in 3.4.6
- moodle/moodlePackagist
From 3.5 · fixed in 3.5.3