Skip to main content
← All vulnerabilities
CVE-2018-16514GHSA-3QV7-98VM-XX2V

A cross-site scripting (XSS) vulnerability in the View Filters page (view_filters_page.php) and Edit Filter page (manage_filter_edit_page.ph

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.17.1
None on Exploit-DB, Metasploit or GitHub

Summary

A cross-site scripting (XSS) vulnerability in the View Filters page (view_filters_page.php) and Edit Filter page (manage_filter_edit_page.php) in MantisBT 2.1.0 through 2.17.0 allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted PATH_INFO. NOTE: this vulnerability exists because of an incomplete fix for CVE-2018-13055.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • mantisbt/mantisbtPackagist

    From 2.1.0 · fixed in 2.17.1

References 1

mantisbt.org