Skip to main content
← All vulnerabilities
CVE-2018-16471GHSA-5R2P-J47H-MHPG

There is a possible XSS vulnerability in Rack before 2.0.6 and 1.6.11.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.0.6, 1.6.11
None on Exploit-DB, Metasploit or GitHub

Summary

There is a possible XSS vulnerability in Rack before 2.0.6 and 1.6.11. Carefully crafted requests can impact the data returned by the `scheme` method on `Rack::Request`. Applications that expect the scheme to be limited to 'http' or 'https' and do not escape the return value could be vulnerable to an XSS attack. Note that applications using the normal escaping mechanisms provided by Rails may not impacted, but applications that bypass the escaping mechanisms, or do not use them may be vulnerable.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Rack Rack

    Version range not reported

  • rackRubyGems

    From 2.0.0 · fixed in 2.0.6

  • rackRubyGems

    fixed in 1.6.11

References 5

groups.google.com

lists.debian.org

lists.opensuse.org

usn.ubuntu.com