Skip to main content
← All vulnerabilities
CVE-2018-16131GHSA-9QGC-P27W-3HJG

The decodeRequest and decodeRequestWith directives in Lightbend Akka HTTP 10.1.x through 10.1.4 and 10.0.x through 10.0.13 allow remote atta

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 10.1.4
None on Exploit-DB, Metasploit or GitHub

Summary

The decodeRequest and decodeRequestWith directives in Lightbend Akka HTTP 10.1.x through 10.1.4 and 10.0.x through 10.0.13 allow remote attackers to cause a denial of service (memory consumption and daemon crash) via a ZIP bomb.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • com.typesafe.akka:akka-http-core_2.12Maven

    From 10.1.0 · fixed in 10.1.4

  • com.typesafe.akka:akka-http-core_2.11Maven

    From 10.1.0 · fixed in 10.1.4

References 4

doc.akka.io

groups.google.com

akka.io

GitHub · akka/akka-http