CVE-2018-14631GHSA-GQRP-QHV8-PHRV
moodle before versions 3.5.2, 3.4.5, 3.3.8 is vulnerable to a boost theme - blog search GET parameter insufficiently filtered.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.3.8, 3.4.5, 3.5.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
moodle before versions 3.5.2, 3.4.5, 3.3.8 is vulnerable to a boost theme - blog search GET parameter insufficiently filtered. The breadcrumb navigation provided by Boost theme when displaying search results of a blog were insufficiently filtered, which could result in reflected XSS if a user followed a malicious link containing JavaScript in the search parameter.
Timeline
- CVE published
- Record last updated
Affected versions
- [UNKNOWN] moodle
3.5.2, 3.4.5, 3.3.8
- moodle/moodlePackagist
From 3.3 · fixed in 3.3.8
- moodle/moodlePackagist
From 3.4 · fixed in 3.4.5
- moodle/moodlePackagist
From 3.5 · fixed in 3.5.2