CVE-2018-14630GHSA-C3PR-H96W-2JJG
moodle before versions 3.5.2, 3.4.5, 3.3.8, 3.1.14 is vulnerable to an XML import of ddwtos could lead to intentional remote code execution.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.5.2, 3.4.5, 3.3.8, 3.1.14
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
moodle before versions 3.5.2, 3.4.5, 3.3.8, 3.1.14 is vulnerable to an XML import of ddwtos could lead to intentional remote code execution. When importing legacy 'drag and drop into text' (ddwtos) type quiz questions, it was possible to inject and execute PHP code from within the imported questions, either intentionally or by importing questions from an untrusted source.
Timeline
- CVE published
- Record last updated
Affected versions
- [UNKNOWN] moodle
3.5.2, 3.4.5, 3.3.8, 3.1.14
- moodle/moodlePackagist
From 3.5.0 · fixed in 3.5.2
- moodle/moodlePackagist
From 3.4.0 · fixed in 3.4.5
- moodle/moodlePackagist
From 3.2.0 · fixed in 3.3.8
- moodle/moodlePackagist
fixed in 3.1.14