Skip to main content
← All vulnerabilities
CVE-2018-1270GHSA-P5HG-3XM3-GCJG

Spring Framework, versions 5.0 prior to 5.0.5 and versions 4.3 prior to 4.3.15 and older unsupported versions, allow applications to expose

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.0.5.RELEASE, 4.3.16.RELEASE
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Spring Framework, versions 5.0 prior to 5.0.5 and versions 4.3 prior to 4.3.15 and older unsupported versions, allow applications to expose STOMP over WebSocket endpoints with a simple, in-memory STOMP broker through the spring-messaging module. A malicious user (or attacker) can craft a message to the broker that can lead to a remote code execution attack.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Spring by Pivotal Spring Framework

    Versions prior to 5.0.5 and 4.3.15

  • org.springframework:spring-messagingMaven

    From 5.0.0.RELEASE · fixed in 5.0.5.RELEASE

  • org.springframework:spring-messagingMaven

    fixed in 4.3.16.RELEASE

References 16

access.redhat.com

Exploit-DB

securityfocus.com

lists.apache.org

oracle.com

pivotal.io

lists.debian.org