Skip to main content
← All vulnerabilities
CVE-2018-1269

Cloud Foundry Loggregator, versions 89.x prior to 89.5 or 96.x prior to 96.1 or 99.x prior to 99.1 or 101.x prior to 101.9 or 102.x prior to

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 89.5, 96.1, 99.1, 101.9, 102.2
None on Exploit-DB, Metasploit or GitHub

Summary

Cloud Foundry Loggregator, versions 89.x prior to 89.5 or 96.x prior to 96.1 or 99.x prior to 99.1 or 101.x prior to 101.9 or 102.x prior to 102.2, does not handle errors thrown while constructing certain http requests. A remote authenticated user may construct malicious requests to cause the traffic controller to leave dangling TCP connections, which could cause denial of service.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Cloud Foundry Loggregator

    From 89.x · fixed in 89.5; From 96.x · fixed in 96.1; From 99.x · fixed in 99.1; From 101.x · fixed in 101.9; From 102.x · fixed in 102.2

References 1

cloudfoundry.org