CVE-2018-1260GHSA-RRPM-PJ7P-7J9Q
Spring Security OAuth, versions 2.3 prior to 2.3.3, 2.2 prior to 2.2.2, 2.1 prior to 2.1.2, 2.0 prior to 2.0.15 and older unsupported versio
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.3, 2.2.2, 2.1.2, 2.0.15
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
Summary
Spring Security OAuth, versions 2.3 prior to 2.3.3, 2.2 prior to 2.2.2, 2.1 prior to 2.1.2, 2.0 prior to 2.0.15 and older unsupported versions contains a remote code execution vulnerability. A malicious user or attacker can craft an authorization request to the authorization endpoint that can lead to remote code execution when the resource owner is forwarded to the approval endpoint.
Timeline
- CVE published
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Pivotal Spring Security OAuth
Version range not reported
- org.springframework.security.oauth:spring-security-oauth2Maven
From 2.3.0 · fixed in 2.3.3
- org.springframework.security.oauth:spring-security-oauth2Maven
From 2.2.0 · fixed in 2.2.2
- org.springframework.security.oauth:spring-security-oauth2Maven
From 2.1.0 · fixed in 2.1.2
- org.springframework.security.oauth:spring-security-oauth2Maven
From 2.0.0 · fixed in 2.0.15
- org.springframework.security.oauth:spring-security-oauth2Maven
From 1.0.0 · through 1.0.5