Skip to main content
← All vulnerabilities
CVE-2018-11777GHSA-RRFQ-G5FQ-FC9C

In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.1.1, 2.3.4
None on Exploit-DB, Metasploit or GitHub

Summary

In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger, sentry or sql standard authorizer is not in use.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Apache Software Foundation Apache Hive

    Version range not reported

  • org.apache.hive:hive-execMaven

    From 3.0.0 · fixed in 3.1.1

  • org.apache.hive:hive-execMaven

    fixed in 2.3.4

References 2

securityfocus.com

lists.apache.org