CVE-2018-11408GHSA-7HWC-2CQ4-6X2W
The security handlers in the Security component in Symfony in 2.7.x before 2.7.48, 2.8.x before 2.8.41, 3.3.x before 3.3.17, 3.4.x before 3.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.7.48, 2.8.41, 3.3.17, 3.4.11, 4.0.11
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The security handlers in the Security component in Symfony in 2.7.x before 2.7.48, 2.8.x before 2.8.41, 3.3.x before 3.3.17, 3.4.x before 3.4.11, and 4.0.x before 4.0.11 have an Open redirect vulnerability when security.http_utils is inlined by a container. NOTE: this issue exists because of an incomplete fix for CVE-2017-16652.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- symfony/symfonyPackagist
From 2.7.0 · fixed in 2.7.48
- symfony/symfonyPackagist
From 2.8.0 · fixed in 2.8.41
- symfony/symfonyPackagist
From 3.3.0 · fixed in 3.3.17
- symfony/symfonyPackagist
From 3.4.0 · fixed in 3.4.11
- symfony/symfonyPackagist
From 4.0.0 · fixed in 4.0.11
- symfony/security-bundlePackagist
From 2.7.0 · fixed in 2.7.48
- symfony/security-bundlePackagist
From 2.8.0 · fixed in 2.8.41
- symfony/security-bundlePackagist
From 3.3.0 · fixed in 3.3.17
- symfony/security-bundlePackagist
From 3.4.0 · fixed in 3.4.11
- symfony/security-bundlePackagist
From 4.0.0 · fixed in 4.0.11