CVE-2018-11407GHSA-35C5-28PG-2QG4
An issue was discovered in the Ldap component in Symfony 2.8.x before 2.8.37, 3.3.x before 3.3.17, 3.4.x before 3.4.7, and 4.0.x before 4.0.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.8.37, 3.3.17, 3.4.7, 4.0.7
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An issue was discovered in the Ldap component in Symfony 2.8.x before 2.8.37, 3.3.x before 3.3.17, 3.4.x before 3.4.7, and 4.0.x before 4.0.7. It allows remote attackers to bypass authentication by logging in with a "null" password and valid username, which triggers an unauthenticated bind. NOTE: this issue exists because of an incomplete fix for CVE-2016-2403.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- symfony/security-corePackagist
From 2.8.0 · fixed in 2.8.37
- symfony/security-corePackagist
From 3.0.0 · fixed in 3.3.17
- symfony/security-corePackagist
From 3.4.0 · fixed in 3.4.7
- symfony/security-corePackagist
From 4.0.0 · fixed in 4.0.7
- symfony/securityPackagist
From 2.8.0 · fixed in 2.8.37
- symfony/securityPackagist
From 3.0.0 · fixed in 3.3.17
- symfony/securityPackagist
From 3.4.0 · fixed in 3.4.7
- symfony/securityPackagist
From 4.0.0 · fixed in 4.0.7
- symfony/symfonyPackagist
From 2.8.0 · fixed in 2.8.37
- symfony/symfonyPackagist
From 3.0.0 · fixed in 3.3.17
- symfony/symfonyPackagist
From 3.4.0 · fixed in 3.4.7
- symfony/symfonyPackagist
From 4.0.0 · fixed in 4.0.7