CVE-2018-10903PYSEC-2018-52GHSA-FCF9-3QW3-GXMJ
A flaw was found in python-cryptography versions between >=1.9.0 and <2.3.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A flaw was found in python-cryptography versions between >=1.9.0 and <2.3. The finalize_with_tag API did not enforce a minimum tag length. If a user did not validate the input length prior to passing it to finalize_with_tag an attacker could craft an invalid payload with a shortened tag (e.g. 1 byte) such that they would have a 1 in 256 chance of passing the MAC check. GCM tag forgeries can cause key leakage.
Timeline
- CVE published
- Record last updated
Affected versions
- [UNKNOWN] python-cryptography
2.3
- cryptographyPyPI
From 1.9 · fixed in 2.3
- cryptographyPyPI
From 1.9.0 · fixed in 2.3