CVE-2018-10891GHSA-P7V9-GJRH-563X
A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.5.1, 3.4.4, 3.3.7, 3.2.10, 3.1.13
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.
Timeline
- CVE published
- Record last updated
Affected versions
- [UNKNOWN] moodle
moodle 3.5.1, moodle 3.4.4, moodle 3.3.7, moodle 3.1.13
- moodle/moodlePackagist
From 3.5.0 · fixed in 3.5.1
- moodle/moodlePackagist
From 3.4.0 · fixed in 3.4.4
- moodle/moodlePackagist
From 3.3.0 · fixed in 3.3.7
- moodle/moodlePackagist
From 3.2.0 · fixed in 3.2.10
- moodle/moodlePackagist
From 3.1.0 · fixed in 3.1.13